Home Search First Look Rules Help TheDaddy.org BlogLogin/Register
By bye hackers
Bugs! - 31 to 60
Return To TheDaddy.org Forum 2 of 4 - <<First  1, 2, 3, 4  Next> Final>>

Amanshu*
Giggity Giggity goo
Wed 9th Aug '06 9:53AM
2708 Posts
Amanshu's Avatar
Member Since
25th Aug '04
Sorry, I was a little drunk when I wrote that! I think I got a little confused and was actually talking about my account. I basically wanted something with a short term cookie - like an hour or so - that I could select when logging on. That way when I ran out of time and got booted half an hour later it was cool that I hadn't logged out.
   

Spanners*
Misses his big brother :(
Wed 9th Aug '06 12:11PM
4597 Posts
Spanners's Avatar
Member Since
7th Apr '03
Aha ok! yeah that sould be fairly easy, hows about a little checkbox on the login form offering a short-term cookie? Leave it with me.
    

Spanners*
Misses his big brother :(
Thu 10th Aug '06 12:46AM
4597 Posts
Spanners's Avatar
Member Since
7th Apr '03
Done! Short term logins expire after an hour of inactivity. Normal logins are currently set to 3 weeks (but this ain't fixed 'cos there's an admin tweak to adjust it)

Also I've added an average rating field to the reviews for where there are second opinions. Trying to figure out how to allow sorting by average rating but it's some heavy heavy SQL.
    

Amanshu*
Giggity Giggity goo
Thu 10th Aug '06 9:47AM
2708 Posts
Amanshu's Avatar
Member Since
25th Aug '04


Spanners was bold enough to comment:

Also I've added an average rating field to the reviews for where there are second opinions. Trying to figure out how to allow sorting by average rating but it's some heavy heavy SQL.



Nicely done! Although wouldn't the SQL become easier if you gave all of the reviews an average rating - even the ones that only had one review? That way you're only searching over one field rather than multiple?
   

Spanners*
Misses his big brother :(
Thu 10th Aug '06 3:51PM
4597 Posts
Spanners's Avatar
Member Since
7th Apr '03


Amanshu was bold enough to comment:

Nicely done! Although wouldn't the SQL become easier if you gave all of the reviews an average rating - even the ones that only had one review? That way you're only searching over one field rather than multiple?


Yeah that would be the way to do it - calculate and store the average rating every time a review or second opinion was made. The reason it's an arse now is 'cos they're not stored but being calculated on the fly as the page is made. Hmmm, maybe I'll play.
    

Amanshu*
Giggity Giggity goo
Mon 4th Sep '06 3:10PM
2708 Posts
Amanshu's Avatar
Member Since
25th Aug '04
Errrr... something weird seems to have happened to the mini-reviews board. The TV series thread seems to have had its first page replaced by the contents of the second page and the second page is now blank...

The films page seems ok though...
   

Spanners*
Misses his big brother :(
Mon 4th Sep '06 7:19PM
4597 Posts
Spanners's Avatar
Member Since
7th Apr '03
What on earth is going on there? Gah!
    

Spanners*
Misses his big brother :(
Thu 7th Sep '06 4:57PM
4597 Posts
Spanners's Avatar
Member Since
7th Apr '03
Fixed!
Damn! After driving myself nuts for the past couple of days I discovered that due to the SQL query I was using to retrieve the reviews from the database, any reviews that didn't have titles or ratings were not shown. The effect you saw was simply the system knowing there to be 31 reviews in the thread but only displaying 30, leaving page 2 with no reviews in it. It's basically a knock-on from when the reviews board was just normal posts - I went through all the posts and put the titles and ratings in the appropiate fields but I missed a couple.
This is why Malcolm's 'Lost' review and Dregan's Jack Daniels review had vanished. Shouldn't happen again

Also !!!!!
    

Demian*
Oh Lordy, Plegaleggole
Thu 7th Sep '06 8:29PM
4678 Posts
Demian's Avatar
Member Since
7th Apr '03


Spanners was bold enough to comment:

Also !!!!!



Wow! What happened?!
  

Spanners*
Misses his big brother :(
Fri 8th Sep '06 9:44AM
4597 Posts
Spanners's Avatar
Member Since
7th Apr '03
No clue, maybe we've started getting some decent search engine hits or summat
What I'm particularly pleased about is that it didn't cause more of the CPU overload errors that plagued us so much on the old server
    

General*
Windows Bob - the best!
Thu 28th Sep '06 3:28PM
4213 Posts
General's Avatar
Member Since
7th Apr '03
When I try and post a second opinion on the Guitar Rig review it says error on page.
    

Diziet
optical moose
Thu 28th Sep '06 5:36PM
2522 Posts
Diziet's Avatar
Member Since
20th Jul '05


General was bold enough to comment:
When I try and post a second opinion on the Guitar Rig review it says error on page.



also, i'd like to change my score of '2' to n/a because i didn't actually get to use the program. i reckon '2' seems a little unfair in the circumstances.

maybe i shouldn't have posted a second opinion at all....hmmm

Spanners*
Misses his big brother :(
Thu 28th Sep '06 11:18PM
4597 Posts
Spanners's Avatar
Member Since
7th Apr '03


General was bold enough to comment:
When I try and post a second opinion on the Guitar Rig review it says error on page.


Huh, not for me it didn't. If it happens again can you copy the text of the error or grab me a screenshot?

And Diz - all reviews have to be numerical 'cos otherwise the 'sort by rating' function gets a bit nonsensical.
    

General*
Windows Bob - the best!
Fri 29th Sep '06 3:03PM
4213 Posts
General's Avatar
Member Since
7th Apr '03


Spanners was bold enough to comment:


General was bold enough to comment:
When I try and post a second opinion on the Guitar Rig review it says error on page.


Huh, not for me it didn't. If it happens again can you copy the text of the error or grab me a screenshot?




Now it works but come up anonymous even though I'm logged in
    

Spanners*
Misses his big brother :(
Fri 29th Sep '06 3:55PM
4597 Posts
Spanners's Avatar
Member Since
7th Apr '03
huh, again not for me!
You sure you're logged in? You tried logging out and in again?
    

General*
Windows Bob - the best!
Fri 29th Sep '06 5:21PM
4213 Posts
General's Avatar
Member Since
7th Apr '03


Spanners was bold enough to comment:
huh, again not for me!
You sure you're logged in? You tried logging out and in again?



Still for me.

And yes I have tried switching it off and then on again: http://www.channel4.com/entertainment/tv/microsites/I/itcrowd/
    

Amanshu*
Giggity Giggity goo
Tue 3rd Oct '06 3:41PM
2708 Posts
Amanshu's Avatar
Member Since
25th Aug '04
It's not really a bug as such, but would it be possible to turn off the dropdown predictive box in the chatroom window? I find it really irritating, and since the chances of it getting it right are doubtful.
   

Spanners*
Misses his big brother :(
Wed 4th Oct '06 1:01AM
4597 Posts
Spanners's Avatar
Member Since
7th Apr '03


Amanshu was bold enough to comment:
It's not really a bug as such, but would it be possible to turn off the dropdown predictive box in the chatroom window? I find it really irritating, and since the chances of it getting it right are doubtful.


I feel your pain my friend, it ain't great but unforunately it's a browser function not a Forum thing. Most browsers do it these days - they cache text you entered into fields and when they find a field with the same name they give you possible completions out of the cache. You can reset it by clearing your history.
    

General*
Windows Bob - the best!
Fri 6th Oct '06 10:16AM
4213 Posts
General's Avatar
Member Since
7th Apr '03
COuldn't post second oppinions again.
Was working for a while but now just says error on page when I click submit.
    

Spanners*
Misses his big brother :(
Fri 6th Oct '06 4:17PM
4597 Posts
Spanners's Avatar
Member Since
7th Apr '03
Gotta be a server fault. PHP code doesn't work intermittently - it either works or it doesn't and since it has worked the code must be sound.
    

Amanshu*
Giggity Giggity goo
Fri 13th Oct '06 2:48PM
2708 Posts
Amanshu's Avatar
Member Since
25th Aug '04
I just noticed that if on the pm page using the delete selected only deletes messages from the inbox, not the outbox.

Also if you select a message and then click on another to view it then the first message will be deselected.

Finally would it be an idea to have a deselect all button to go with the select all button?
   

Amanshu*
Giggity Giggity goo
Wed 25th Oct '06 11:34AM
2708 Posts
Amanshu's Avatar
Member Since
25th Aug '04
Annnnnddddd the A-Team review in the mini-reviews board has an average rating of 1...
   

Spanners*
Misses his big brother :(
Wed 25th Oct '06 12:48PM
4597 Posts
Spanners's Avatar
Member Since
7th Apr '03
Fixed it. Yeahhhhhhh.
The function that removes trailing zeros after the decimal point was getting a bit to enthusiastic.
    

Amanshu*
Giggity Giggity goo
Thu 26th Oct '06 12:27PM
2708 Posts
Amanshu's Avatar
Member Since
25th Aug '04
Hmph - custom titles no longer seem to work for non-admins. The buttons there but clicking it don't seem to do anything...
   

Agentgonzo
There's no pee in catheter!
Thu 26th Oct '06 12:47PM
811 Posts
Agentgonzo's Avatar
Member Since
8th Aug '06

Amanshu was bold enough to comment:
Hmph - custom titles no longer seem to work for non-admins. The buttons there but clicking it don't seem to do anything...



And they don't even appear in IE (or IETab) - IE 6 or 6.5 I think. I've closed the window and can't be bothered to reopen it to check.
  

General*
Windows Bob - the best!
Thu 26th Oct '06 1:01PM
4213 Posts
General's Avatar
Member Since
7th Apr '03


Amanshu was bold enough to comment:
Hmph - custom titles no longer seem to work for non-admins. The buttons there but clicking it don't seem to do anything...



Works for me, but then I am an admin
    

Spanners*
Misses his big brother :(
Thu 26th Oct '06 1:32PM
4597 Posts
Spanners's Avatar
Member Since
7th Apr '03
Cool fixed that, it had a button rather than a submit. D'oh!
And I'm pretty sure it's been like that ever since I added the feature!
    

Amanshu*
Giggity Giggity goo
Wed 15th Nov '06 4:58PM
2708 Posts
Amanshu's Avatar
Member Since
25th Aug '04
I can't seem to add a second opinion to Mogwai's Super Sweet 16 rant.

I can still add them to other posts, just not that one. It looks like it's working, it just... doesn't.
   

Spanners*
Misses his big brother :(
Thu 16th Nov '06 7:27AM
4597 Posts
Spanners's Avatar
Member Since
7th Apr '03
Huh, that just worked for me.
What's your browser? Did the 'processing' page come up?
    

Amanshu*
Giggity Giggity goo
Thu 16th Nov '06 9:47AM
2708 Posts
Amanshu's Avatar
Member Since
25th Aug '04
I'm using Firefox 2 at the moment. It brings up the popup and lets me write the review. Then when I click submit the popup disappears and the main page refreshes exactly as I'd expect, just without my 2nd Opinion being included...
   

Bookmark With: Post to DiggDigg   Post to DeliciousDelicious   Post to RedditReddit   Post to FacebookFacebook   Post to StumbleuponStumbleupon
Return To TheDaddy.org Forum 2 of 4 - <<First  1, 2, 3, 4  Next> Final>>

Time Zone is Greenwich Mean Time You are Visible
Html Tags are On Smileys are On
Anonymous Posting is Not AllowedSpanners is The Daddy