Home Search First Look Rules Help TheDaddy.org BlogLogin/Register
By bye hackers
Swearing at Word tables of content - 1 to 2
Return To Techy Corner

Amanshu*
Giggity Giggity goo
Fri 28th Nov '08 4:11PM
2708 Posts
Amanshu's Avatar
Member Since
25th Aug '04
With nowhere else to turn I throw myself on the bitter mercies of Techy Corner.

I'm currently writing a document in Word (which I consider to be bad enough). The document neatly splits into two sections - the legal blurb at the beginning that is cut and pasted from some other document, and the actual content that is new and useful (well, I say useful...). Anyway because of this I have two sections with two different layouts. I tried creating one Table of content for the entire document, but because of the differences between the two it ended up looking rubbish.

So the only other option was to create two tables of content - one for each section. This was fine and good, but I appear to have hit one very small (and completely annoying) problem. I can't change the formatting of the page numbers to be different.

The preamble section is irrelevant to the content, so it has roman numeral numbering. It's not until the actual document starts that the page numbering starts properly with romantic numerals. I'd like the two tables of content to follow this theme, with the first being in roman numerals and the second being in romantic numerals.

Any ideas? Other than give up and go to the pub?
   

Epicure_mammon
I'm not crazy cause I take the RIGHT pills :)
Sun 30th Nov '08 11:44AM
140 Posts
Epicure_mammon's Avatar
Member Since
12th Dec '06
I think you need to take advantage of the "Outline Level" feature. I assume you've got all the formatting neatly in styles for both sections, but the styles you're using for the 2nd section are different from the first. If you ensure that the "Outline Level" setting (under format paragraph) is set to the correct value for each style, your single TOC for the entire document should "just work".

For example, say you're using "Heading 1" for all the chapter titles in section one and "new style I've created v2" for all the equivalent headings in the second section. If you open the styles and formatting side bar - right click on "heading 1" and select modify - grab "Paragraph" from the Format drop-down and in the top right of the "Indents and Spacing" tab you'll see an "Outline Level" setting. In the case of "Heading 1" its greyed out, because Heading 1 is a built in style. If you do the same for "new style I've created v2" you'll be able to change the value. Change it to whatever "Heading 1" was - in my case it was Level 1 - and in a TOC it will be treated in the same way as a Heading 1 style.

Hope that helps!
  

Bookmark With: Post to DiggDigg   Post to DeliciousDelicious   Post to RedditReddit   Post to FacebookFacebook   Post to StumbleuponStumbleupon
Return To Techy Corner

Time Zone is Greenwich Mean Time You are Visible
Html Tags are On Smileys are On
Anonymous Posting is Not AllowedKelly is The Daddy